hakyll-skeleton/shell.nix
Fiscal Velvet Poet 3497666514
nix: add alejandra
2024-07-24 19:42:44 +10:00

17 lines
443 B
Nix

{
pkgs ? import <nixpkgs> {},
mkShell,
stylish-haskell,
}:
with pkgs;
mkShell {
buildInputs = [
alejandra # The Uncompromising Nix Code Formatter
nix # Powerful package manager, makes packaging reliable & reproducible
stylish-haskell # A simple Haskell code prettifier
tea # Gitea official CLI client
treefmt # one CLI to format the code tree
zlib # Lossless data-compression library
];
}