8aa2357df5
resolves #18
50 lines
1.1 KiB
Nix
50 lines
1.1 KiB
Nix
{
|
|
self,
|
|
hakyll-skeleton,
|
|
reciproka-web,
|
|
ragenix,
|
|
colmena,
|
|
nix,
|
|
nixpkgs,
|
|
nixpkgsUnstable,
|
|
resrok-web,
|
|
utils,
|
|
voc-web,
|
|
...
|
|
} @ inputs:
|
|
(utils.lib.eachDefaultSystem (system: let
|
|
pkgs = nixpkgs.legacyPackages."${system}";
|
|
in {
|
|
devShell =
|
|
pkgs.callPackage
|
|
./shell.nix {
|
|
inherit (ragenix.packages."${pkgs.system}") ragenix;
|
|
inherit (colmena.packages."${pkgs.system}") colmena;
|
|
inherit (nix.packages."${pkgs.system}") nix;
|
|
inherit (nixpkgsUnstable.legacyPackages."${pkgs.system}") alejandra;
|
|
};
|
|
}))
|
|
// {
|
|
colmena = {
|
|
meta = {
|
|
description = "NixOS deployment for Reciproka Kolectiva";
|
|
name = "reciproka-ops";
|
|
nixpkgs = import nixpkgs {
|
|
system = "x86_64-linux";
|
|
overlays = [];
|
|
};
|
|
};
|
|
toscano = {
|
|
imports = [
|
|
./nixos/hosts/toscano/configuration.nix
|
|
ragenix.nixosModules.default
|
|
];
|
|
};
|
|
};
|
|
# The below lines are in the wrong place
|
|
#nixosConfigurations = import ./nixos/configurations.nix (inputs
|
|
# // {
|
|
# inherit inputs;
|
|
# });
|
|
}
|