reciproka-ops/flake.nix
2023-08-28 10:55:40 +10:00

34 lines
1,000 B
Nix

{
description = "reciproka-ops deployment";
inputs = {
colmena.url = "github:zhaofengli/colmena/?ref=v0.4.0";
ragenix = {
url = "github:yaxitech/ragenix";
inputs.nixpkgs.follows = "nixpkgs";
};
hakyll-skeleton = {
flake = false;
url = git+https://reciproka.dev/reciproka/hakyll-skeleton/?ref=consensus;
};
reciproka-web = {
flake = false;
url = git+https://reciproka.dev/reciproka/reciproka-web/?ref=reciproka-migration;
};
resrok-web = {
flake = false;
url = git+https://reciproka.dev/resrok/resrok-web/?ref=consensus;
};
nix.url = "github:NixOS/nix/?ref=2.10.3";
nixpkgs.url = github:NixOS/nixpkgs/?ref=nixos-23.05;
nixpkgsUnstable.url = github:NixOS/nixpkgs/?ref=nixos-unstable;
utils.url = "github:numtide/flake-utils";
voc-web = {
flake = false;
url = git+https://reciproka.dev/voc/voc-web/?ref=consensus;
};
};
outputs = {...} @ args: import ./outputs.nix args;
}