25 lines
497 B
Nix
25 lines
497 B
Nix
# Configuration for my pantheon desktop requirements
|
|
{
|
|
config,
|
|
pkgs,
|
|
...
|
|
}: {
|
|
services = {
|
|
libinput.enable = true; # Enable touchpad support.
|
|
pantheon = {
|
|
apps.enable = true;
|
|
contractor.enable = true;
|
|
};
|
|
xserver = {
|
|
enable = true; # Enable the X11 windowing system.
|
|
desktopManager = {
|
|
pantheon.enable = true;
|
|
};
|
|
};
|
|
};
|
|
programs = {
|
|
dconf.enable = true;
|
|
pantheon-tweaks.enable = true; # additional system settings
|
|
};
|
|
}
|