17 lines
461 B
Nix
17 lines
461 B
Nix
# Spotify service configuration
|
|
{
|
|
config,
|
|
pkgs,
|
|
lib,
|
|
...
|
|
}: {
|
|
services.spotifyd = {
|
|
enable = false; # Enable the Spotify daemon.
|
|
config = "\n username = ${pkgs.gnupg}/bin/gpg -q --for-your-eyes-only --no-tty -d ~/.spotify/userName.gpg\n password_cmd = ${pkgs.gnupg}/bin/gpg -q --for-your-eyes-only --no-tty -d ~/.spotify/passwd.gpg\n ";
|
|
};
|
|
|
|
environment.systemPackages = with pkgs; [
|
|
ncspot # ncurses Spotify client
|
|
];
|
|
}
|